Skip to main content
VulnerabilityPublished

CVE-2025-13983: Drupal Tagify · Cross-site Scripting

Affects Drupal TagifySource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.2.44 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.44
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Drupal Tagify to 1.2.44.

Affected software

ProductAffectedFixed in
DrupalTagifyAffected
  • <1.2.44
Fixed in
  • 1.2.44

AI-suggested

  1. Immediately upgrade the Drupal Tagify module to version 1.2.44 or later once available to address the vulnerability.
  2. Implement strict input validation and sanitization on all user-supplied data, especially in fields enhanced by Tagify, to prevent injection of malicious scripts.
  3. Deploy Content Security Policies (CSP) to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks.
  4. Educate users and administrators about the risks of phishing and social engineering attacks that could trigger this vulnerability, emphasizing cautious interaction with unexpected links or inputs.
  5. Monitor web server and application logs for unusual activity or error messages that may indicate attempted exploitation.
  6. Use web application firewalls (WAFs) with updated rule sets to detect and block common XSS payloads targeting Drupal applications.
  7. Conduct regular security assessments and penetration testing focusing on input handling and client-side script execution.
  8. Ensure that session management mechanisms are robust, including the use of HttpOnly and Secure flags on cookies to mitigate session hijacking risks.

Description

CVE-2025-13983 is a medium severity Cross-Site Scripting (XSS) vulnerability in the Drupal Tagify module versions before 1.2.44. It arises from improper neutralization of input during web page generation, allowing attackers with low privileges and requiring user interaction to inject malicious scripts. The vulnerability impacts confidentiality and integrity by enabling script execution in the context of authenticated users, potentially leading to session hijacking or data manipulation. No known exploits are currently reported in the wild. European organizations using Drupal with the vulnerable Tagify versions should prioritize patching to mitigate risks. The vulnerability has a CVSS score of 5.4, reflecting its moderate impact and exploitability. Countries with significant Drupal adoption and critical web infrastructure, such as Germany, France, and the UK, are most likely to be affected.

References

Community reviews

Loading reviews…