CVE-2025-13985: Drupal Entity Share · Incorrect Authorization
Affects Drupal Entity ShareSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.13.0 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.13.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Drupal Entity Share to 3.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalEntity Share | Affected
| Fixed in
|
AI-suggested
1. Upgrade the Drupal Entity Share module to version 3.13.0 or later as soon as the patch is released to address the authorization flaw. 2. If you cannot patch yet, implement strict access control policies at the web server or application firewall level to restrict access to sensitive entity sharing endpoints. 3. Review and tighten Drupal user permissions related to entity sharing to minimize exposure. 4. Monitor web server and Drupal logs for unusual or unauthorized access attempts indicative of forceful browsing. 5. Employ network segmentation and limit public exposure of Drupal instances that handle sensitive data. 6. Conduct regular security audits and penetration testing focusing on authorization controls within Drupal modules. 7. Educate administrators and developers about the risks of incorrect authorization and best practices for secure module configuration. 8. Subscribe to Drupal security advisories and CVE databases to stay informed about patch releases and emerging threats related to this vulnerability.
Description
CVE-2025-13985 is an incorrect authorization vulnerability in the Drupal Entity Share module versions before 3.13.0. It allows unauthenticated attackers to perform forceful browsing, potentially accessing resources they should not be authorized to view. The vulnerability has a CVSS score of 5.3, indicating medium severity, with low impact on confidentiality and no impact on integrity or availability. Exploitation requires no privileges or user interaction and can be performed remotely. No known exploits are currently reported in the wild. European organizations using Drupal with the vulnerable Entity Share module should prioritize patching or mitigating this issue to prevent unauthorized data exposure. Countries with high Drupal adoption and critical public or private sector infrastructures using Drupal are more likely to be affected.