Skip to main content
CVE-2025-14180VulnerabilityPublished

CVE-2025-14180: PHP · NULL Pointer Dereference

Affects PHPSource CVE Database V5

0

Not known to be exploited · CVSS 8.2 High · fixed in 8.6.0 : patch PHP soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.6.0, 8.5.1, 8.5.0 +7
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.1.*, < 8.1.34
  • ≥ 8.2.*, < 8.2.30
  • ≥ 8.3.*, < 8.3.29
  • ≥ 8.4.*, < 8.4.16
  • ≥ 8.5.*, < 8.5.1
Fixed in–
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • <8.1.34
  • >=8.1.0 <8.2.0
  • <8.2.30
  • >=8.2.0 <8.3.0
  • <8.3.29
  • >=8.3.0 <8.4.0
  • <8.4.16
  • >=8.4.0 <8.5.0
  • <8.5.1
  • >=8.5.0 <8.6.0
Fixed in
  • 8.1.34
  • 8.2.0
  • 8.2.30
  • 8.3.0
  • 8.3.29
  • 8.4.0
  • 8.4.16
  • 8.5.0
  • 8.5.1
  • 8.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-14180, European organizations should prioritize upgrading PHP to the fixed versions: 8.1.34 or later, 8.2.30 or later, 8.3.29 or later, 8.4.16 or later, or 8.5.1 or later. If immediate upgrading is not feasible, a practical workaround is to disable PDO::ATTR_EMULATE_PREPARES for PostgreSQL connections, forcing the use of native prepared statements which do not trigger this vulnerability. This can be done by setting the PDO attribute explicitly in application code or configuration. Additionally, input validation and sanitization should be enhanced to prevent invalid character sequences from reaching the database layer. Web application firewalls (WAFs) can be configured to detect and block suspicious payloads containing invalid byte sequences. Monitoring PHP error logs and server crash reports can help detect exploitation attempts early. Organizations should also review their incident response plans to handle potential denial-of-service scenarios caused by this vulnerability. Finally, maintaining an up-to-date asset inventory to identify all PHP instances using PostgreSQL with emulated prepares enabled is critical for comprehensive remediation.

Description

In PHP versions 8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1 when using the PDO PostgreSQL driver with PDO::ATTR_EMULATE_PREPARES enabled, an invalid character sequence (such as \x99) in a prepared statement parameter may cause the quoting function PQescapeStringConn to return NULL, leading to a null pointer dereference in pdo_parse_params() function. This may lead to crashes (segmentation fault) and affect the availability of the target server.

References

Community reviews

Loading reviews…