Skip to main content
CVE-2025-14338VulnerabilityPublished

CVE-2025-14338: https://github.com/ShadowBlip inputplumber · Improper Access Control

Affects https://github.com/ShadowBlip inputplumberSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.5 High : upgrade to 0.63.0 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.63.0, 0.69.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade inputplumber to 0.63.0; shadowblip/inputplumber to 0.69.0.

Affected software

ProductAffectedFixed in
https://github.com/ShadowBlipinputplumberAffected
  • ≥ ?, < 0.63.0
Fixed in
  • 0.63.0
GitHubshadowblip/inputplumberpkg:github/shadowblip/inputplumberOther threatsAffected
  • <0.69.0
Fixed in
  • 0.69.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade inputplumber and any related Polkit components to version 0.69.0 or later once available. 2. If you cannot patch yet, disable or restrict access to inputplumber and Polkit services, especially on multi-user systems. 3. Implement strict local user access controls and monitor for unusual privilege escalation attempts. 4. Employ system integrity monitoring to detect unauthorized changes to Polkit configurations or binaries. 5. Use mandatory access controls (e.g., SELinux, AppArmor) to limit the impact of potential exploitation. 6. Educate users about the risks of interacting with untrusted local applications or scripts that could trigger the vulnerability. 7. Regularly audit system logs for suspicious Polkit authorization events. 8. Consider network segmentation to isolate critical systems from less trusted user environments. 9. Maintain up-to-date backups and incident response plans to quickly recover from potential compromises.

Description

Polkit authentication dis isabled by default and a race condition in the Polkit authorization check in versions before v0.69.0 can lead to the same issues as in CVE-2025-66005.

References

Community reviews

Loading reviews…