Skip to main content
CVE-2025-14719VulnerabilityPublished

CVE-2025-14719: Relevanssi (WordPress plugin) · SQL Injection

Affects Relevanssi (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.9 Medium : upgrade to 4.26.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.26.0, 2.29.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Relevanssi to 4.26.0; Relevanssi Premium to 2.29.0.

Affected software

ProductAffectedFixed in
RelevanssiAffected
  • <4.26.0
Fixed in
  • 4.26.0
Relevanssi PremiumAffected
  • <2.29.0
Fixed in
  • 2.29.0

AI-suggested

1. Immediately update the Relevanssi plugin to version 4.26.0 or later, and Relevanssi Premium to version 2.29.0 or later once available. 2. If you cannot patch yet, restrict contributor and higher roles to trusted users only, minimizing the risk of exploitation from compromised accounts. 3. Implement strict role-based access controls and monitor contributor activities for unusual behavior. 4. Employ Web Application Firewalls (WAFs) with SQL Injection detection rules tailored to WordPress environments to block suspicious queries. 5. Regularly audit WordPress plugins for updates and security advisories, integrating automated vulnerability scanning into the development and deployment pipelines. 6. Consider disabling or limiting the use of Relevanssi search functionality if it is not critical, reducing the attack surface. 7. Backup WordPress databases frequently and securely to enable recovery in case of compromise. 8. Educate content contributors about phishing and credential security to prevent account takeover. 9. Monitor logs for anomalous SQL queries or access patterns indicative of exploitation attempts.

Description

CVE-2025-14719 is a medium severity SQL Injection vulnerability in the Relevanssi WordPress plugin versions before 4.26.0 and Relevanssi Premium before 2.29.0. It allows users with contributor or higher roles to inject malicious SQL code due to improper sanitization and escaping of input parameters. The vulnerability does not require user interaction but does require authenticated access with elevated privileges. Exploitation can lead to unauthorized disclosure of sensitive data, impacting confidentiality without affecting integrity or availability. No known exploits are currently reported in the wild. European organizations using vulnerable versions of Relevanssi are at risk, especially those with contributors who have elevated WordPress roles.

References

Community reviews

Loading reviews…