CVE-2025-14795: Stop Spammers Classic (WordPress plugin) · Cross-Site Request Forgery (CSRF)
Affects Stop Spammers Classic (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.3 Medium · fixed in 2026.1 : update Stop Spammers Classic (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| webguyioStop Spammers Classic | Affected
| Fixed in– |
AI-suggested
A partial patch was applied in version 2026.1, but the vulnerability remains. No official full fix or patch link is provided. Until fully patched, administrators should be cautious about clicking untrusted links while logged into WordPress with administrative privileges.
Description
The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The vulnerability was partially patched in version 2026.1.
References
- wordfence.com/threat-intel/vulnerabilities/id/5d6f38d7-a769-422d-ae3f-565cb1cc8a73?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/stop-spammer-registrations-plugin/tags/2025.4/classes/ss_addtoallowlist.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3436357/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3440788/ (opens in a new tab)