Skip to main content
CVE-2025-14955VulnerabilityPublished Updated

CVE-2025-14955: Open5GS · Improper Initialization

Affects Open5GSSource CVE Database V5

0

Not known to be exploited · CVSS 6.3 Medium.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
GitHubopen5gs/open5gspkg:github/open5gs/open5gsOther threatsAffected
  • =2.7.0
  • =2.7.1
  • =2.7.2
  • =2.7.3
  • =2.7.4
  • =2.7.5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-14955, organizations should immediately apply the official patch identified by commit 773117aa5472af26fc9f80e608d3386504c3bdb7 to all affected Open5GS instances. Network operators should verify their Open5GS version and upgrade to a fixed version beyond 2.7.5. In addition to patching, it is recommended to implement strict network segmentation and firewall rules to restrict access to PFCP interfaces, limiting exposure to untrusted networks. Monitoring and logging of PFCP traffic should be enhanced to detect anomalous or malformed Create PDR messages that could indicate exploitation attempts. Employing intrusion detection systems (IDS) with signatures for known exploit patterns can provide early warning. Regular security audits and vulnerability assessments of 5G core components should be conducted to identify and remediate similar issues proactively. Finally, maintaining an up-to-date inventory of Open5GS deployments and ensuring rapid patch management processes are critical to minimizing exposure.

Description

A vulnerability was found in Open5GS up to 2.7.5. Affected by this vulnerability is the function ogs_pfcp_handle_create_pdr in the library lib/pfcp/handler.c of the component PFCP. The manipulation results in improper initialization. It is possible to launch the attack remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. The exploit has been made public and could be used. The patch is identified as 773117aa5472af26fc9f80e608d3386504c3bdb7. It is best practice to apply a patch to resolve this issue.

References

Community reviews

Loading reviews…