CVE-2025-14975: Custom Login Page Customizer (WordPress plugin) · Improper Privilege Management
Affects Custom Login Page Customizer (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.5.4 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Custom Login Page Customizer (WordPress plugin) to 2.5.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Custom Login Page Customizer | Affected
| Fixed in
|
AI-suggested
1. Immediately update the Custom Login Page Customizer plugin to version 2.5.4 or later, where the vulnerability is patched. 2. If immediate update is not possible, disable or remove the plugin temporarily to prevent exploitation. 3. Implement multi-factor authentication (MFA) on WordPress administrator accounts to add an additional security layer beyond passwords. 4. Monitor WordPress logs for unusual password reset requests or multiple failed login attempts, especially those targeting administrator accounts. 5. Restrict access to the WordPress admin and login pages using IP whitelisting or web application firewalls (WAF) to limit exposure. 6. Conduct regular security audits and vulnerability scans on WordPress installations to detect outdated plugins or suspicious activity. 7. Educate site administrators about the risks of using outdated plugins and the importance of timely patching. 8. Consider deploying intrusion detection/prevention systems (IDS/IPS) that can detect anomalous password reset patterns. 9. Backup WordPress sites regularly to enable quick recovery in case of compromise. 10. Review user accounts for unauthorized changes post-incident and reset passwords if suspicious activity is detected.
Description
CVE-2025-14975 is a high-severity vulnerability in the Custom Login Page Customizer WordPress plugin versions before 2.5.4. It allows unauthenticated attackers to reset the password of any user, including administrators, by sending a few crafted requests with knowledge of the username. This improper privilege management flaw (CWE-269) enables full account takeover without requiring user interaction or prior authentication. The vulnerability impacts confidentiality, integrity, and availability of affected WordPress sites. Although no known exploits are currently in the wild, the ease of exploitation and critical impact make timely patching essential. European organizations using this plugin on WordPress sites are at risk, especially those with high-value targets or public-facing portals. Mitigation involves immediate plugin updates and enhanced monitoring of password reset activities. Countries with large WordPress user bases and significant e-commerce or governmental web presence, such as Germany, France, and the UK, are most likely to be affected.