Skip to main content
CVE-2025-15033VulnerabilityPublished Updated

CVE-2025-15033: WooCommerce (WordPress plugin) · Insecure Direct Object Reference

Affects WooCommerce (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 10.4.3 : update WooCommerce (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.4.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
Automattic WooCommerceAffected
  • =8.1.0
  • =8.2.0
  • =8.3.0
  • =8.4.0
  • =8.5.0
  • =8.6.0
  • =8.7.0
  • =8.8.0
  • =8.9.0
  • =9.0.0
  • =9.1.0
  • =9.2.0
  • =9.3.0
  • =9.4.0
  • =9.5.0
  • =9.6.0
  • =9.7.0
  • =9.8.0
  • =9.9.0
  • =10.0.0
  • =10.1.0
  • =10.2.0
  • =10.3.0
  • =10.4.0
Fixed in–

AI-suggested

1. Immediately update WooCommerce to version 10.4.3 or later, or at minimum to the earliest patched version 8.1.3 if running an affected version between 8.1.0 and 10.4.0. 2. Review and harden site configurations related to guest checkout and order data access controls to ensure strict authorization enforcement. 3. Implement additional access control layers such as Web Application Firewalls (WAF) with custom rules to detect and block anomalous requests attempting to access order data via user-controlled keys. 4. Conduct thorough audits and penetration testing focused on authorization logic around order data retrieval endpoints. 5. Monitor logs for unusual access patterns by authenticated customers querying order data not belonging to them. 6. Educate development and operations teams about the importance of secure authorization checks when handling user-supplied keys or parameters. 7. If immediate patching is not feasible, consider temporarily disabling guest checkout or restricting access to order data APIs until patched. 8. Regularly review WooCommerce and WordPress security advisories to stay informed about new vulnerabilities and patches.

Description

A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.

References

Community reviews

Loading reviews…