Skip to main content
VulnerabilityPublished

CVE-2025-15386: Responsive Lightbox & Gallery (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Responsive Lightbox & Gallery (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.6.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Responsive Lightbox & Gallery (WordPress plugin) to 2.6.1.

Affected software

ProductAffectedFixed in
Responsive Lightbox & GalleryAffected
  • >=1.7.0 <2.6.1
Fixed in
  • 2.6.1

AI-suggested

To mitigate CVE-2025-15386, organizations should immediately upgrade the Responsive Lightbox & Gallery plugin to version 2.6.1 or later, where the vulnerability is patched. If upgrading is not immediately possible, disable the lightbox feature for comments to prevent exploitation. Implement strict comment moderation policies to ensure that no untrusted or suspicious comments are approved. Employ Web Application Firewalls (WAFs) with rules designed to detect and block XSS payloads in comment submissions. Additionally, enable Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts on the site. Regularly audit and sanitize all user-generated content, especially in comment sections. Monitor logs for unusual comment submissions or script injections. Educate site administrators about the risks of approving comments without proper review. Finally, consider deploying security plugins that provide enhanced input validation and XSS protection.

Description

The Responsive Lightbox & Gallery WordPress plugin before 2.6.1 is vulnerable to an Unauthenticated Stored-XSS attack due to flawed regex replacement rules that can be abused by posting a comment with a malicious link when lightbox for comments are enabled and then approved.

References

Community reviews

Loading reviews…