CVE-2025-15444: IAMB Crypt::Sodium::XS · Dependency on Vulnerable Third-Party Component
Affects IAMB Crypt::Sodium::XSSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.000042 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.000042
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade IAMB Crypt::Sodium::XS to 0.000042.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| IAMBCrypt::Sodium::XS | Affected
| Fixed in
|
AI-suggested
To mitigate this vulnerability, European organizations should: 1) Immediately upgrade Crypt::Sodium::XS to version 0.000042 or later, which includes the patched libsodium 1.0.20-stable version. 2) Conduct a thorough inventory of all Perl applications and dependencies to identify usage of vulnerable Crypt::Sodium::XS versions or direct libsodium dependencies. 3) Audit custom cryptographic implementations that rely on libsodium to ensure they do not use the affected crypto_core_ed25519_is_valid_point function in an unsafe manner. 4) Implement strict input validation and sanitization for any untrusted data fed into cryptographic functions. 5) Monitor security advisories for any emerging exploits or patches related to this vulnerability. 6) Employ runtime application self-protection (RASP) or intrusion detection systems to detect anomalous cryptographic operations. 7) Engage with software vendors and open-source communities to ensure timely updates and patches. 8) Consider cryptographic agility strategies to allow rapid replacement of vulnerable components in the future.
Description
CVE-2025-15444 is a critical vulnerability in the Crypt::Sodium::XS Perl module, which depends on a vulnerable version of libsodium (<= 1.0.20). The underlying libsodium flaw (CVE-2025-69277) mishandles validation of elliptic curve points in certain cryptographic operations, potentially allowing invalid points that compromise cryptographic guarantees. This can lead to severe impacts on confidentiality, integrity, and availability without requiring authentication or user interaction. The vulnerability affects all versions of Crypt::Sodium::XS prior to 0.000042, which updates libsodium to a fixed version released January 3, 2026. European organizations relying on this module for cryptographic functions in Perl applications are at risk, especially in sectors handling sensitive data or critical infrastructure. Mitigation requires immediate upgrading to Crypt::Sodium::XS version 0.000042 or later and auditing dependent applications for use of vulnerable libsodium versions.