Skip to main content
CVE-2025-23209VulnerabilityPublished Updated

CVE-2025-23209: craftcms cms · Code Injection

Affects craftcms cmsSource CVE Database V5

0

Exploited in the wild · KEV due 13 Mar 2025 · 21% EPSS : upgrade to 5.5.8 or 4.13.8 now.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else.
EPSS
21.6% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.8, 4.13.8
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 18 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 33 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub_M

    , 5 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. , 33 days after disclosure

  4. KEV remediation due

    US federal deadline

    , 54 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade craftcms/cms to 5.5.8 or 4.13.8.

Affected software

ProductAffectedFixed in
GitHubcraftcms/cmspkg:github/craftcms/cmsOther threatsAffected
  • <4.13.8
  • <5.5.8
Fixed in
  • 4.13.8
  • 5.5.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.

References

Community reviews

Loading reviews…