CVE-2025-24859: Apache Roller · Insufficient Session Expiration
Affects Apache RollerSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low · fixed in 6.1.5 : update Apache Roller when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.1.5
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:N/AU:N/R:U/RE:L/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.roller/rollerpkg:maven/org.apache.roller/rollerOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should upgrade Apache Roller installations to version 6.1.5 or later, where the vulnerability is fixed by proper session invalidation upon password changes. Until upgrading is possible, administrators should consider implementing manual session invalidation procedures, such as forcing all users to log out after password resets or disabling user accounts temporarily. Monitoring active sessions and implementing session timeout policies can reduce the window of exposure. Additionally, integrating Apache Roller with centralized authentication and session management solutions (e.g., Single Sign-On with session revocation capabilities) can help mitigate risks. It is also advisable to audit logs for unusual session activity following password changes and educate users on the importance of logging out from all devices after password updates. Finally, restricting administrative privileges and enforcing strong password policies reduce the likelihood of session compromise.
Description
A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.