CVE-2025-27802: Optimizely Episerver Content Management System (CMS) · XSS or 'Cross-site Scripting'
Affects Optimizely Episerver Content Management System (CMS)Source CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 11.37.5 or 11.37.3 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.37.5, 11.37.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:L/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade episerver.cms.ui to 11.37.5 or 11.37.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
NuGetepiserver.cms.corepkg:nuget/episerver.cms.coreOther threats | Affected
| Fixed in– |
NuGetepiserver.cms.uipkg:nuget/episerver.cms.uiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade to the fixed versions of Episerver CMS: 11.21.4 or later for 11.x series and 12.22.1 or later for 12.x series, along with corresponding CMS.UI updates. If immediate patching is not feasible, implement strict input validation and sanitization on RTE fields to neutralize potentially malicious scripts. Limit the number of users with 'WebEditor' or higher privileges and enforce strong authentication mechanisms, including multi-factor authentication (MFA), to reduce the risk of account compromise. Monitor CMS logs for unusual editing activities and preview page accesses. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Conduct regular security training for CMS users to recognize phishing and social engineering attempts that could lead to credential theft. Finally, perform periodic security assessments and penetration testing focused on CMS components to detect similar vulnerabilities proactively.
Description
The Episerver Content Management System (CMS) by Optimizely was affected by multiple Stored Cross-Site Scripting (XSS) vulnerabilities. This allowed an authenticated attacker to execute malicious JavaScript code in the victim's browser. RTE properties (text fields), which could be used in the "Edit" section of the CMS, allowed the input of arbitrary text. It was possible to input malicious JavaScript code in these properties that would be executed if a user visits the previewed page. Attackers needed at least the role "WebEditor" in order to exploit this issue. Affected products: Version 11.X: EPiServer.CMS.Core (<11.21.4) with EPiServer.CMS.UI (<11.37.5), Version 12.X: EPiServer.CMS.Core (<12.22.1) with EPiServer.CMS.UI (<11.37.3)