CVE-2025-2945: pgAdmin 4 · Code Injection
Affects pgAdmin 4Source CVE Database V5
Not known to be exploited · public exploit available (Metasploit) · 56% EPSS · CVSS 9.9 Critical : upgrade to 9.2 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 56.3% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade pgadmin4 to 9.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIpgadmin4pkg:pypi/pgadmin4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2025-2945, organizations should immediately upgrade pgAdmin 4 to version 9.2 or later, where the vulnerability is addressed. Until the upgrade is applied, restrict network access to the vulnerable endpoints (/sqleditor/query_tool/download and /cloud/deploy) using firewalls, web application firewalls (WAFs), or network segmentation to limit exposure. Implement strict access controls and authentication mechanisms to reduce the risk of unauthorized access. Monitor logs for suspicious POST requests targeting these endpoints, especially those containing unusual payloads in the query_commited or high_availability parameters. Employ runtime application self-protection (RASP) or intrusion detection systems (IDS) to detect and block attempts to exploit eval() injection. Review and sanitize all user inputs rigorously in custom deployments or extensions of pgAdmin 4 to prevent similar code injection flaws. Educate administrators about the risks of unsafe eval() usage and encourage secure coding practices. Finally, maintain up-to-date backups and incident response plans to quickly recover from potential compromises.
Description
Remote Code Execution security vulnerability in pgAdmin 4 (Query Tool and Cloud Deployment modules). The vulnerability is associated with the 2 POST endpoints; /sqleditor/query_tool/download, where the query_commited parameter and /cloud/deploy endpoint, where the high_availability parameter is unsafely passed to the Python eval() function, allowing arbitrary code execution. This issue affects pgAdmin 4: before 9.2.