Skip to main content
VulnerabilityPublished Updated

CVE-2025-3103: CLEVER (WordPress plugin) · External Control of File Name or Path

Affects CLEVER (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.5 High · fixed in 2.4 : patch CLEVER (WordPress plugin) soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
LambertGroup CLEVER - HTML5 Radio Player With History - Shoutcast and Icecast - Elementor Widget AddonAffected
  • =0
Fixed in–

AI-suggested

Version 2.4 includes a partial patch, but a complete fix is not confirmed. Until a full fix is released, consider restricting access to the affected 'history.php' file or disabling the vulnerable plugin if possible.

Description

The CLEVER - HTML5 Radio Player With History - Shoutcast and Icecast - Elementor Widget Addon plugin for WordPress is vulnerable to arbitrary file read due to insufficient file path validation in the 'history.php' file in all versions up to, and including, 2.4. This makes it possible for unauthenticated attackers to read arbitrary files on the affected site's server, which may contain sensitive information including database credentials. The vulnerability was partially patched in version 2.4.

References

Community reviews

Loading reviews…