Skip to main content
VulnerabilityPublished

CVE-2025-32785: pi-hole web · Cross-site Scripting

Affects pi-hole webSource CVE Database V5

0

Public exploit available · CVSS 2.0 Low : upgrade to 6.3 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pi-hole/web to 6.3.

Affected software

ProductAffectedFixed in
GitHubpi-hole/webpkg:github/pi-hole/webOther threatsAffected
  • <6.3
Fixed in
  • 6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade all Pi-hole Admin Interface installations to version 6.3 or later, where the vulnerability has been patched with proper input sanitization. Until upgrades can be applied, organizations should restrict access to the Pi-hole admin interface to trusted administrators only, ideally via network segmentation or VPN access. Implement strong authentication mechanisms, such as multi-factor authentication, to reduce the risk of unauthorized access. Regularly audit user accounts and permissions to ensure only authorized personnel can modify subscribed lists. Educate administrators about the risks of injecting untrusted input and the importance of cautious interaction with the admin interface. Monitor logs for unusual activity related to the Tools section or gravity database updates. Consider deploying web application firewalls (WAFs) with rules to detect and block XSS payloads targeting the Pi-hole interface. Finally, maintain an up-to-date inventory of Pi-hole deployments to ensure timely patch management.

Description

Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level advertisement and internet tracker blocking application. Pi-hole Admin Interface versions prior to 6.3 are vulnerable to cross-site scripting (XSS) via the Address field in the Subscribed Lists group management section. An authenticated user can inject malicious JavaScript by adding a payload to the Address field when creating or editing a list entry. The vulnerability is triggered when another user navigates to the Tools section and performs a gravity database update. The Address field does not properly sanitize input, allowing special characters and script tags to bypass validation. This has been patched in version 6.3.

References

Community reviews

Loading reviews…