Skip to main content
VulnerabilityPublished Updated

CVE-2025-3302: Xagio SEO (WordPress plugin) · Cross-site Scripting

Affects Xagio SEO (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 7.1.0.0 : patch Xagio SEO (WordPress plugin) soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
xagio Xagio SEO – AI Powered SEOAffected
  • =0
Fixed in–

AI-suggested

Users should verify if newer versions beyond 7.1.0.16 have addressed this issue by consulting the vendor's advisory or update channels. Until a full fix is confirmed, consider disabling or restricting use of the affected plugin to mitigate risk. Monitor vendor communications for official patches or updates.

Description

The Xagio SEO – AI Powered SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘HTTP_REFERER’ parameter in all versions up to, and including, 7.1.0.16 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.1.0.0.

References

Community reviews

Loading reviews…