Skip to main content
VulnerabilityPublished Updated

CVE-2025-34228: Vasion Print Virtual Appliance Host · Missing Authentication

Affects Vasion Print Virtual Appliance HostSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 25.1.102 : patch Vasion Print Virtual Appliance Host soon.

Data as of 26 Oct 2026, 11:42 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.1.102
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Vasion Print Virtual Appliance HostAffected
  • =0
Fixed in–

AI-suggested

The vulnerability has been confirmed as remediated by the vendor, although the exact patched version is not specified. Users should upgrade to version 25.1.102 or later for the Virtual Appliance Host and 25.1.1413 or later for the Application to ensure the fix is applied. Until upgraded, restrict external access to the vulnerable script if possible.

Description

Vasion Print (formerly PrinterLogic) Virtual Appliance Host prior to version 25.1.102 and Application prior to version 25.1.1413 (VA/SaaS deployments) contain a server-side request forgery (SSRF) vulnerability. The `/var/www/app/console_release/lexmark/update.php` script is reachable from the internet without any authentication. The PHP script builds URLs from user‑controlled values and then invokes either 'curl_exec()` or `file_get_contents()` without proper validation. Because the endpoint is unauthenticated, any remote attacker can supply a hostname and cause the server to issue requests to internal resources. This enables internal network reconnaissance, potential pivoting, or data exfiltration. This vulnerability has been confirmed to be remediated, but it is unclear as to when the patch was introduced.

References

Community reviews

Loading reviews…