Skip to main content
VulnerabilityPublished Updated

CVE-2025-34302: IPFire · XSS or 'Cross-site Scripting'

Affects IPFireSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.29 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ipfire/ipfire to 2.29.

Affected software

ProductAffectedFixed in
Ipfireipfire/ipfirepkg:rpm/ipfire/ipfireOther threatsAffected
  • <2.29
Fixed in
  • 2.29

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-34302, organizations should prioritize upgrading IPFire installations to version 2.29 (Core Update 198) or later, where the vulnerability is addressed. If immediate patching is not feasible, administrators should restrict access to the IPFire web interface to trusted networks and users only, minimizing the risk of unauthorized authenticated access. Implement strong authentication mechanisms, including multi-factor authentication, to reduce the likelihood of credential compromise. Regularly audit service entries and remove any suspicious or unexpected entries that could contain injected scripts. Employ web application firewalls (WAFs) or reverse proxies with XSS filtering capabilities to detect and block malicious payloads targeting the PROT parameter. Additionally, educate administrators and users about the risks of stored XSS and encourage cautious behavior when interacting with the IPFire management interface. Monitoring logs for unusual POST requests or changes to service configurations can help detect exploitation attempts early.

Description

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the PROT parameter when creating a new service. When a user adds a service, the application issues an HTTP POST request with the ACTION parameter set to saveservice, and the protocol type is specified in the PROT parameter. The value of this parameter is stored and later rendered in the web interface without proper sanitization or encoding, allowing injected scripts to execute in the context of other users viewing the affected service entry.

References

Community reviews

Loading reviews…