Skip to main content
VulnerabilityPublished

CVE-2025-34303: IPFire · XSS or 'Cross-site Scripting'

Affects IPFireSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.29 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade IPFire to 2.29.

Affected software

ProductAffectedFixed in
IPFire.org IPFireAffected
  • <2.29
Fixed in
  • 2.29

AI-suggested

To mitigate CVE-2025-34303, European organizations should prioritize upgrading IPFire installations to version 2.29 (Core Update 198) or later, where the vulnerability is addressed. If immediate patching is not feasible, administrators should restrict access to the IPFire web interface to trusted networks and enforce strong authentication mechanisms, including multi-factor authentication, to reduce the risk of unauthorized access. Regularly audit whitelist entries and other user-generated content for suspicious or unexpected remarks that could indicate attempted exploitation. Implement web application firewall (WAF) rules to detect and block suspicious input patterns targeting the IGNORE_ENTRY_REMARK parameter. Additionally, organizations should educate administrators about the risks of stored XSS and encourage cautious handling of input fields in management interfaces. Monitoring logs for unusual POST requests to /cgi-bin/ids.cgi can help detect exploitation attempts. Finally, consider isolating management interfaces from general user networks and employing network segmentation to limit the impact of any compromise.

Description

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the IGNORE_ENTRY_REMARK parameter when adding a whitelisted host. When a whitelisted host is added, an HTTP POST request is sent to the Request-URI /cgi-bin/ids.cgi and the remark for the entry is provided in the IGNORE_ENTRY_REMARK parameter. The value of this parameter is stored and later rendered in the web interface without proper sanitization or encoding, allowing injected scripts to execute in the context of other users who view the affected whitelist entry.

References

Community reviews

Loading reviews…