CVE-2025-34313: IPFire · XSS or 'Cross-site Scripting'
Affects IPFireSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.29 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade IPFire to 2.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| IPFire.org IPFire | Affected
| Fixed in
|
AI-suggested
- Upgrade IPFire installations to version 2.29 (Core Update 198) or later as soon as the patch becomes available to ensure the vulnerability is remediated.
- If you cannot patch yet, restrict access to the IPFire web interface to trusted networks and users only, using network segmentation and VPNs.
- Implement strict role-based access controls to limit which authenticated users can create or modify user quota rules.
- Monitor IPFire logs and user activities for suspicious quota rule creations or modifications that could indicate attempted exploitation.
- Educate administrators about the risks of stored XSS and encourage cautious handling of user inputs in the management interface.
- Consider deploying web application firewalls (WAFs) or reverse proxies that can detect and block malicious payloads targeting the quota management endpoints.
- Regularly audit and sanitize existing quota entries to remove any potentially malicious scripts.
- Follow vendor advisories closely for official patches or mitigation guidance.
Description
IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the QUOTA_USERS parameter when creating a user quota rule. When a user adds a new user quota rule the application issues an HTTP POST request to /cgi-bin/urlfilter.cgi with the MODE parameter set to USERQUOTA and the assigned user(s) provided in the QUOTA_USERS parameter. The value of this parameter is stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected quota entry.