Skip to main content
VulnerabilityPublished Updated

CVE-2025-35036: Hibernate Validator · Code Injection

Affects Hibernate ValidatorSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.3 High : upgrade to 7.0.0 or 6.2.0 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0, 6.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.hibernate.validator/hibernate-validator to 7.0.0 or 6.2.0.

Affected software

ProductAffectedFixed in
Mavenorg.hibernate.validator/hibernate-validatorpkg:maven/org.hibernate.validator/hibernate-validatorOther threatsAffected
  • <6.2.0
  • <7.0.0
Fixed in
  • 6.2.0
  • 7.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately assess their use of Hibernate Validator and identify affected versions prior to 6.2.0 and 7.0.0. The primary mitigation is to upgrade to Hibernate Validator version 6.2.0 or 7.0.0 or later, where the unsafe EL interpolation has been removed. Until upgrades can be applied, organizations should audit and sanitize all user inputs that may be included in constraint violation messages to prevent injection of malicious EL expressions. Implementing strict input validation and output encoding can reduce risk. Additionally, disabling or restricting Expression Language evaluation in validation messages, if configurable, is recommended. Organizations should monitor network traffic and logs for suspicious EL expressions or unusual error messages indicative of exploitation attempts. Employing runtime application self-protection (RASP) or web application firewalls (WAF) with custom rules to detect and block EL injection patterns can provide temporary defense. Finally, security teams should update incident response plans to include this vulnerability and educate developers about safe usage of validation frameworks.

Description

Hibernate Validator before 6.2.0 and 7.0.0, by default and depending how it is used, may interpolate user-supplied input in a constraint violation message with Expression Language. This could allow an attacker to access sensitive information or execute arbitrary Java code. Hibernate Validator as of 6.2.0 and 7.0.0 no longer interpolates custom constraint violation messages with Expression Language and strongly recommends not allowing user-supplied input in constraint violation messages. CVE-2020-5245 and CVE-2025-4428 are examples of related, downstream vulnerabilities involving Expression Language intepolation of user-supplied data.

References

Community reviews

Loading reviews…