CVE-2025-36577: Dell Wyse Management Suite · Cross-site Scripting
Affects Dell Wyse Management SuiteSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.2 when convenient.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Dell Wyse Management Suite to 5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Dell Wyse Management Suite | Affected
| Fixed in
|
AI-suggested
To mitigate this vulnerability, European organizations should prioritize upgrading Dell Wyse Management Suite to version 5.2 or later once available, as this will likely include the necessary security patches. If you cannot patch yet, organizations should restrict access to the management suite to trusted administrative users only, enforce strong authentication mechanisms such as multi-factor authentication (MFA), and limit remote access through VPNs or secure tunnels with strict access controls. Regularly audit and monitor administrative activities and logs for suspicious behavior indicative of attempted exploitation. Implement network segmentation to isolate management consoles from general user networks and the internet, reducing exposure to external attackers. Additionally, conduct user training to recognize and avoid triggering malicious scripts, and consider deploying web application firewalls (WAFs) that can detect and block XSS payloads targeting the management interface. Finally, review and harden input validation and output encoding policies within custom integrations or scripts interacting with the management suite to reduce injection risks.
Description
Dell Wyse Management Suite, versions prior to WMS 5.2, contain an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Script injection.