Skip to main content
VulnerabilityPublished Updated

CVE-2025-38351: Linux kernel · KVM: x86/hyper-v: Skip non-canonical addresses during PV TLB flush

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.5 Medium · fixed in 6.8.0-1046.49~22.04.1 : update Linux kernel when convenient.

Data as of 3 Nov 2026, 17:43 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.0-1046.49~22.04.1, 6.8.0-1051.57~22.04.1, 6.8.0-1046.53~22.04.1 +32
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-100.100
Fixed in
  • 6.8.0-100.100
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.49
Fixed in
  • 6.8.0-1046.49
Ubuntu 24.04 LTSlinux-aws-6.14pkg:deb/ubuntu/linux-aws-6.14?arch=source&distro=nobleOther threatsAffected
  • <6.14.0-1017.17~24.04.1
Fixed in
  • 6.14.0-1017.17~24.04.1
Ubuntu 24.04 LTSlinux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1046.52
Fixed in
  • 6.8.0-1046.52
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch addressing this vulnerability is available in Linux kernel versions 6.8.0 and later, including specific fixed versions such as 6.8.0-1046.49~22.04.1 and others listed in the advisory. Users should upgrade to these fixed kernel versions to mitigate the issue. No additional mitigation actions are required as the fix properly handles non-canonical GVAs during TLB flush hypercalls.

Description

CVE-2025-38351 is a vulnerability in the Linux kernel's KVM subsystem affecting x86 Hyper-V guests. It involves improper handling of non-canonical guest virtual addresses (GVAs) during paravirtualized TLB flush hypercalls, which can cause Intel CPUs to trigger a VM-Fail warning. The flaw is addressed by skipping non-canonical GVAs during processing to prevent INVVPID failures. This issue affects certain Linux kernel versions prior to 6.8.0 and specific older versions. A fix is available in Linux kernel 6.8.0 and later.

References

Community reviews

Loading reviews…