Skip to main content
CVE-2025-42616VulnerabilityPublished

CVE-2025-42616: CIRCL Vulnerability-Lookup · Cross-Site Request Forgery (CSRF)

Affects CIRCL Vulnerability-LookupSource CVE Database V5

0

Not known to be exploited · CVSS 7.0 High : upgrade to 2.18.0 soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.18.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade CIRCL Vulnerability-Lookup to 2.18.0.

Affected software

ProductAffectedFixed in
CIRCL Vulnerability-LookupAffected
  • =0
  • <2.18.0
Fixed in
  • 2.18.0

AI-suggested

European organizations should immediately upgrade Vulnerability-Lookup to version 2.18.0 or later, where the vulnerability is patched. Until the upgrade is applied, organizations should implement compensating controls such as restricting access to the Vulnerability-Lookup application to trusted networks and users, employing web application firewalls (WAFs) to detect and block suspicious GET requests that attempt state changes, and enforcing strict session management and monitoring for unusual activity. Security teams should audit logs for unexpected state-changing operations initiated via GET requests. User education to avoid clicking on untrusted links while authenticated can reduce risk. Additionally, reviewing and hardening CSRF protections across all web applications, ensuring that all state-changing endpoints require POST methods and CSRF tokens, will help prevent similar vulnerabilities. Regular vulnerability scanning and penetration testing should verify the effectiveness of these mitigations.

Description

Some endpoints in vulnerability-lookup that modified application state (e.g.changing database entries, user data, configurations, or other privileged actions) may have been accessible via HTTP GET requests without requiring a CSRF token. This flaw leaves the application vulnerable to Cross-Site Request Forgery (CSRF) attacks: an attacker who tricks a logged-in user into visiting a malicious website could cause the user’s browser to issue GET requests that perform unintended state-changing operations in the context of their authenticated session. Because the server would treat these GET requests as valid (since no CSRF protection or POST method enforcement was in place), the attacker could exploit this to escalate privileges, change settings, or carry out other unauthorized actions without needing the user’s explicit consent or awareness. The fix ensures that all state-changing endpoints now require HTTP POST requests and include a valid CSRF token. This enforces that state changes cannot be triggered by arbitrary cross-site GET requests. This issue affects Vulnerability-Lookup: before 2.18.0.

References

Community reviews

Loading reviews…