Skip to main content
VulnerabilityPublished Updated

CVE-2025-4601: RH (WordPress theme) · Improper Privilege Management

Affects RH (WordPress theme)Source CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 4.4.0 : patch RH (WordPress theme) soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.9% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
InspiryThemes RH - Real Estate WordPress ThemeAffected
  • =0
Fixed in–

AI-suggested

Upgrade the RH - Real Estate WordPress Theme to version 4.4.1 or later, where the vulnerability is fully patched. Versions prior to 4.4.1, including 4.4.0, are vulnerable or only partially fixed. No other mitigations are indicated by the vendor advisory.

Description

The "RH - Real Estate WordPress Theme" theme for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 4.4.0. This is due to the theme not properly restricting user roles that can be updated as part of the inspiry_update_profile() function. This makes it possible for authenticated attackers, with subscriber-level access and above, to set their role to that of an administrator. The vulnerability was partially patched in version 4.4.0, and fully patched in version 4.4.1.

References

Community reviews

Loading reviews…