Skip to main content
CVE-2025-4680VulnerabilityPublished

CVE-2025-4680: upKeeper Instant Privilege Access · Improper Input Validation

Affects upKeeper Instant Privilege AccessSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 1.4.0 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade upKeeper Instant Privilege Access to 1.4.0.

Affected software

ProductAffectedFixed in
upKeeper Solutions upKeeper Instant Privilege AccessAffected
  • =0
  • <1.4.0
Fixed in
  • 1.4.0

AI-suggested

1. Immediate upgrade to upKeeper Instant Privilege Access version 1.4.0 or later once available, as this will contain the official patch addressing the improper input validation issue. 2. If you cannot patch yet, restrict local access to systems running upKeeper Instant Privilege Access to trusted personnel only and enforce strict user access controls to minimize the risk of exploitation. 3. Implement enhanced monitoring and logging around privileged access management activities to detect unusual or unauthorized access attempts that could indicate exploitation attempts. 4. Conduct targeted user awareness training focusing on the risks of social engineering and the importance of cautious interaction with privilege elevation prompts or unusual system requests. 5. Review and tighten access control policies and configurations within the PAM solution to limit the potential impact of misconfigurations or input manipulation. 6. Employ network segmentation and endpoint protection measures to contain any potential breach originating from exploitation of this vulnerability. 7. Coordinate with upKeeper Solutions for any interim mitigation guidance and subscribe to their security advisories for timely updates.

Description

Improper Input Validation vulnerability in upKeeper Solutions upKeeper Instant Privilege Access allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects upKeeper Instant Privilege Access: before 1.4.0.

References

Community reviews

Loading reviews…