CVE-2025-47410: Apache Geode · Cross-Site Request Forgery (CSRF)
Affects Apache GeodeSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.15.2 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.15.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.geode/geode to 1.15.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.geode/geodepkg:maven/org.apache.geode/geodeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all Apache Geode deployments to version 1.15.2 or later, which contains the official fix for this CSRF vulnerability. In addition to patching, organizations should implement strict network segmentation to limit access to the Management and Monitoring REST API, restricting it to trusted administrative networks only. Employing Web Application Firewalls (WAFs) with custom rules to detect and block suspicious CSRF patterns can provide an additional layer of defense. Organizations should also enforce multi-factor authentication (MFA) for accessing management interfaces and educate users about the risks of clicking untrusted links to reduce the likelihood of successful social engineering. Monitoring and logging API access for anomalous commands or unusual patterns can help detect exploitation attempts early. Finally, reviewing and hardening session management policies to reduce session lifetime and scope can limit the window of opportunity for attackers.
Description
Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.