Skip to main content
VulnerabilityPublished Updated

CVE-2025-48042: ash · Incorrect Authorization

Affects ashSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 3.5.39 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.39, 5d1b6a5d00771fd468a509778637527b5218be9a
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ash to 3.5.39; ash to 5d1b6a5d00771fd468a509778637527b5218be9a.

Affected software

ProductAffectedFixed in
ash-projectashAffected
  • >=0.1.1 <3.5.39
Fixed in
  • 3.5.39
ash-projectashAffected
  • ≥ 4c41344126b0aba09ec3085517000f8aefec299e, < 5d1b6a5d00771fd468a509778637527b5218be9a
Fixed in
  • 5d1b6a5d00771fd468a509778637527b5218be9a
Hexashpkg:hex/ashOther threatsAffected
  • >=0.1.1 <3.5.39
Fixed in
  • 3.5.39

CPE configurations (1)

  • cpe:2.3:a:ash-project:ash:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to affected functionalities and monitor for suspicious activity related to bulk operations. Avoid deploying affected versions in sensitive environments if possible.

Description

Incorrect Authorization vulnerability in ash-project ash allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects ash: from 0.1.1 before 3.5.39.

References

Community reviews

Loading reviews…