Skip to main content
VulnerabilityPublished Updated

CVE-2025-48043: ash · Incorrect Authorization

Affects ashSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 3.6.2 soon.

Data as of 26 Oct 2026, 09:08 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.6.2, 66d81300065b970da0d2f4528354835d2418c7ae
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ash to 3.6.2; ash to 66d81300065b970da0d2f4528354835d2418c7ae.

Affected software

ProductAffectedFixed in
ash-projectashAffected
  • >=0.1.1 <3.6.2
Fixed in
  • 3.6.2
ash-projectashAffected
  • ≥ 4c41344126b0aba09ec3085517000f8aefec299e, < 66d81300065b970da0d2f4528354835d2418c7ae
Fixed in
  • 66d81300065b970da0d2f4528354835d2418c7ae
Hexashpkg:hex/ashOther threatsAffected
  • >=0.1.1 <3.6.2
Fixed in
  • 3.6.2

CPE configurations (1)

  • cpe:2.3:a:ash-project:ash:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider implementing additional access controls or compensating controls outside the affected software to mitigate risk.

Description

Incorrect Authorization vulnerability in ash-project ash allows Authentication Bypass. This issue affects ash: from 0.1.1 before 3.6.2.

References

Community reviews

Loading reviews…