CVE-2025-50989: n/a
Source CVE Database V5
Not known to be exploited · 10% EPSS · CVSS 8.8 High · fixed in 25.1.8 : patch affected systems soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 10.1% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 25.1.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
AI-suggested
European organizations should immediately audit their OPNsense deployments to identify affected versions, particularly version 25.1. In the interim, restrict administrative access to the OPNsense web interface using network segmentation, VPNs, or IP whitelisting to reduce exposure. Enforce strong multi-factor authentication (MFA) for all administrator accounts to mitigate risks from credential compromise. Conduct thorough input validation reviews and consider implementing web application firewalls (WAFs) that can detect and block command injection patterns targeting the Bridge Interface Edit endpoint. Regularly audit logs for suspicious POST requests or unusual command executions. Additionally, consider deploying intrusion detection/prevention systems (IDS/IPS) tuned to detect exploitation attempts. Organizations should also review and harden system configurations to minimize the privileges of the web service where feasible, limiting the impact of potential exploitation. Finally, establish incident response plans specifically addressing firewall compromise scenarios to ensure rapid containment and recovery.
Description
OPNsense before 25.1.8 contains an authenticated command injection vulnerability in its Bridge Interface Edit endpoint (interfaces_bridge_edit.php). The span POST parameter is concatenated into a system-level command without proper sanitization or escaping, allowing an administrator to inject arbitrary shell operators and payloads. Successful exploitation results in remote code execution with the privileges of the web service (typically root), potentially leading to full system compromise or lateral movement. This vulnerability arises from inadequate input validation and improper handling of user-supplied data in backend command invocations.