Skip to main content
CVE-2025-5244VulnerabilityPublished Updated

CVE-2025-5244: GNU Binutils · Memory Corruption

Affects GNU BinutilsSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium · fixed in 2.45 : update GNU Binutils when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.45
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
GNUBinutilsAffected
  • =2.0
  • =2.1
  • =2.2
  • =2.3
  • =2.4
  • =2.5
  • =2.6
  • =2.7
  • =2.8
  • =2.9
  • =2.10
  • =2.11
  • =2.12
  • =2.13
  • =2.14
  • =2.15
  • =2.16
  • =2.17
  • =2.18
  • =2.19
  • =2.20
  • =2.21
  • =2.22
  • =2.23
  • =2.24
  • =2.25
  • =2.26
  • =2.27
  • =2.28
  • =2.29
  • =2.30
  • =2.31
  • =2.32
  • =2.33
  • =2.34
  • =2.35
  • =2.36
  • =2.37
  • =2.38
  • =2.39
  • =2.40
  • =2.41
  • =2.42
  • =2.43
  • =2.44
Fixed in–

AI-suggested

Upgrade GNU Binutils to version 2.45 or later, which contains the official fix for this vulnerability. Since this is a local attack vector, restricting local access and privileges can also reduce risk.

Description

A vulnerability was found in GNU Binutils up to 2.44. It has been rated as critical. Affected by this issue is the function elf_gc_sweep of the file bfd/elflink.c of the component ld. The manipulation leads to memory corruption. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 2.45 is able to address this issue. It is recommended to upgrade the affected component.

References

Community reviews

Loading reviews…