CVE-2025-52479: JuliaWeb HTTP.jl · CRLF Injection
Affects JuliaWeb HTTP.jlSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 1.10.17 soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.10.17, 1.6.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 25 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade github.com/juliaweb/HTTP.jl to 1.10.17; github.com/juliaweb/URIs.jl to 1.6.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Gogithub.com/juliaweb/HTTP.jlpkg:golang/github.com/juliaweb/HTTP.jlOther threats | Affected
| Fixed in
|
Gogithub.com/juliaweb/URIs.jlpkg:golang/github.com/juliaweb/URIs.jlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading to HTTP.jl version 1.10.17 and URIs.jl version 1.6.0, which include proper URI validation to prevent CRLF injection. As a temporary workaround, users should manually validate and sanitize any URIs before passing them to these packages. Patch status is confirmed by the vendor advisory embedded in the description.
Description
HTTP.jl provides HTTP client and server functionality for Julia, and URIs.jl parses and works with Uniform Resource Identifiers (URIs). URIs.jl prior to version 1.6.0 and HTTP.jl prior to version 1.10.17 allows the construction of URIs containing CR/LF characters. If user input was not otherwise escaped or protected, this can lead to a CRLF injection attack. Users of HTTP.jl should upgrade immediately to HTTP.jl v1.10.17, and users of URIs.jl should upgrade immediately to URIs.jl v1.6.0. The check for valid URIs is now in the URI.jl package, and the latest version of HTTP.jl incorporates that fix. As a workaround, manually validate any URIs before passing them on to functions in this package.