Skip to main content
CVE-2025-52569VulnerabilityPublished

CVE-2025-52569: JuliaWeb GitHub.jl · Improper Input Validation

Affects JuliaWeb GitHub.jlSource CVE Database V5

0

Not known to be exploited · CVSS 6.6 Medium : upgrade to 5.9.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade github.com/juliaweb/GitHub.jl to 5.9.1.

Affected software

ProductAffectedFixed in
Gogithub.com/juliaweb/GitHub.jlpkg:golang/github.com/juliaweb/GitHub.jlOther threatsAffected
  • <5.9.1
Fixed in
  • 5.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade to GitHub.jl version 5.9.1 or later is essential to ensure the vulnerability is patched. 2. Review and audit all internal and third-party Julia codebases and automation scripts that utilize GitHub.jl to identify usage of vulnerable versions. 3. Implement strict input validation and sanitization on any user-supplied parameters before passing them to GitHub.jl functions, as an additional safeguard. 4. Monitor network traffic to and from `api.github.com` for unusual or unexpected API calls that may indicate exploitation attempts. 5. Employ runtime application self-protection (RASP) or API gateway controls that can detect and block path traversal patterns in API requests. 6. Educate developers and DevOps teams about secure coding practices, emphasizing the risks of improper input validation in third-party libraries. 7. Maintain an inventory of all dependencies and ensure timely updates to minimize exposure to known vulnerabilities. 8. Consider implementing GitHub API access controls and audit logging to detect anomalous access patterns that could result from exploitation.

Description

GitForge.jl is a unified interface for interacting with Git "forges." Versions prior to 5.9.1 lack input validation of input validation for user-provided values in certain functions. In the `GitHub.repo()` function, the user can provide any string for the `repo_name` field. These inputs are not validated or safely encoded and are sent directly to the server. This means a user can add path traversal patterns like `../` in the input to access any other endpoints on `api.github.com` that were not intended. Users should upgrade immediately to v5.9.1 or later to receive a patch. All prior versions are vulnerable. No known workarounds are available.

References

Community reviews

Loading reviews…