Skip to main content
VulnerabilityPublished

CVE-2025-52570: mbuesch letmein · Improper Control of Interaction Frequency

Affects mbuesch letmeinSource CVE Database V5

0

Not known to be exploited · CVSS 1.7 Low : upgrade to 10.2.1 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
1.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mbuesch/letmein to 10.2.1.

Affected software

ProductAffectedFixed in
GitHubmbuesch/letmeinpkg:github/mbuesch/letmeinOther threatsAffected
  • <10.2.1
Fixed in
  • 10.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediate upgrade to letmein version 10.2.1 or later, where the connection limiter issue is patched, is the most effective mitigation.
  2. Implement network-level rate limiting and connection throttling on firewalls or intrusion prevention systems to restrict the number of simultaneous connections to letmein services, providing an additional layer of defense.
  3. Monitor network traffic for unusual spikes in connection attempts to the letmeind and letmeinfwd services, enabling early detection of potential abuse.
  4. Restrict access to letmein services to trusted IP ranges where possible, reducing exposure to external attackers.
  5. Employ logging and alerting mechanisms specifically for connection anomalies related to port knocking services.
  6. Conduct regular audits of letmein configurations to ensure that security parameters such as 'num-connections' are correctly applied and effective. These steps go beyond generic advice by focusing on compensating controls and proactive monitoring tailored to the nature of this vulnerability.

Description

Letmein is an authenticating port knocker. Prior to version 10.2.1, The connection limiter is implemented incorrectly. It allows an arbitrary amount of simultaneously incoming connections (TCP, UDP and Unix socket) for the services letmeind and letmeinfwd. Therefore, the command line option num-connections is not effective and does not limit the number of simultaneously incoming connections. This issue has been patched in version 10.2.1.

References

Community reviews

Loading reviews…