CVE-2025-5275: Charitable (WordPress plugin) · Cross-site Scripting
Affects Charitable (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.4 Medium · fixed in 1.8.6.2 : update Charitable (WordPress plugin) when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.6.2
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| smub Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations & More | Affected
| Fixed in– |
AI-suggested
The vulnerability is fully fixed in Charitable plugin version 1.8.6.2. Users should upgrade to version 1.8.6.2 or later to remediate this issue. Versions up to and including 1.8.6.1 are vulnerable, with only a partial fix applied in 1.8.6.1. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the version history described in the advisory.
Description
The Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the privacy settings fields in all versions up to, and including, 1.8.6.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled. This issue was partially fixed in version 1.8.6.1 and fully fixed in version 1.8.6.2.