Skip to main content
VulnerabilityPublished

CVE-2025-52880: gotson komga · Improper Control of Interaction Frequency

Affects gotson komgaSource CVE Database V5

0

Not known to be exploited · CVSS 4.2 Medium : upgrade to 1.22.0 when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.22.0
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gotson/komga to 1.22.0.

Affected software

ProductAffectedFixed in
GitHubgotson/komgapkg:github/gotson/komgaOther threatsAffected
  • >=1.8.0 <1.22.0
Fixed in
  • 1.22.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediate upgrade to Komga version 1.22.0 or later, which contains the official patch addressing this vulnerability.
  2. Implement strict content validation and sanitization for all EPUB files before adding them to the Komga library to prevent malicious payloads from being introduced.
  3. Restrict administrative access to the Komga server and limit the number of users with admin privileges to reduce the attack surface.
  4. Employ network segmentation and firewall rules to limit Komga server exposure, especially restricting API access to trusted networks or VPNs.
  5. Monitor logs for unusual activity related to EPUB file uploads and admin interactions with the reader to detect potential exploitation attempts.
  6. Educate administrators on the risks of opening untrusted EPUB files within Komga and encourage verification of source integrity.
  7. Consider deploying Web Application Firewalls (WAF) with custom rules to detect and block XSS payloads in HTTP requests/responses related to Komga.
  8. Regularly audit and update all third-party components and dependencies used by Komga to minimize exposure to other vulnerabilities. These steps go beyond generic advice by focusing on content validation, access control, and monitoring tailored to the specific attack vector involving EPUB files and admin user interaction.

Description

Komga is a media server for comics, mangas, BDs, magazines and eBooks. A Cross-Site Scripting (XSS) vulnerability has been discovered in versions 1.8.0 through 1.21.3 when serving EPUB resources, either directly from the API, or when reading using the epub reader. The vulnerability lets an attacker perform actions on the victim's behalf. When targeting an admin user, this can be combined with controlling a server-side command to achieve arbitrary code execution. For this vulnerability to be exploited, a malicious EPUB file has to be present in a Komga library, and subsequently accessed in the Epub reader by an admin user. Version 1.22.0 contains a patch for the issue.

References

Community reviews

Loading reviews…