Skip to main content
CVE-2025-52937VulnerabilityPublished

CVE-2025-52937: PointCloudLibrary pcl · Vulnerability

Affects PointCloudLibrary pclSource CVE Database V5

0

Not known to be exploited · CVSS 2.0 Low : upgrade to 1.14.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.14.0
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/S:N/AU:N/R:A/V:D/RE:M/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade pointcloudlibrary/pcl to 1.14.0.

Affected software

ProductAffectedFixed in
GitHubpointcloudlibrary/pclpkg:github/pointcloudlibrary/pclOther threatsAffected
  • <1.14.0
Fixed in
  • 1.14.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should audit their use of the PointCloudLibrary to identify any instances of versions older than 1.14.0 or builds configured with WITH_SYSTEM_ZLIB=FALSE. Immediate mitigation involves upgrading to PCL version 1.14.0 or later, which addresses the vulnerability. For environments where upgrading is not feasible, recompiling PCL with system zlib enabled is recommended to mitigate the vulnerability. Additionally, restricting local access to systems running vulnerable PCL versions and enforcing strict privilege separation can reduce the risk of exploitation. Organizations should also monitor internal systems for unusual behavior related to point cloud processing tasks and implement integrity checks on critical data processed by PCL modules. Since no patches are currently linked, maintaining close contact with the PCL project for updates and applying patches promptly upon release is essential. Finally, incorporating this vulnerability into vulnerability management and asset inventory systems will ensure ongoing awareness and timely remediation.

Description

Vulnerability in PointCloudLibrary PCL (surface/src/3rdparty/opennurbs modules). This vulnerability is associated with program files crc32.C. This vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib (WITH_SYSTEM_ZLIB=FALSE).

References

Community reviews

Loading reviews…