Skip to main content
CVE-2025-52938VulnerabilityPublished

CVE-2025-52938: dail8859 NotepadNext · Out-of-bounds Read

Affects dail8859 NotepadNextSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 0.11 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.11
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/S:N/AU:Y/R:A/V:D/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade dail8859/NotepadNext to 0.11.

Affected software

ProductAffectedFixed in
GitHubdail8859/NotepadNextpkg:github/dail8859/NotepadNextOther threatsAffected
  • <0.11
Fixed in
  • 0.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Given the lack of an official patch, European organizations should implement the following specific mitigations: 1) Restrict the use of NotepadNext to trusted users and environments, minimizing exposure to untrusted Lua scripts. 2) Employ application whitelisting and sandboxing techniques to isolate NotepadNext processes, preventing unauthorized code execution and limiting memory access scope. 3) Monitor and audit Lua script usage within NotepadNext to detect anomalous or unauthorized script compilation activities. 4) Temporarily disable or limit Lua code compilation features in NotepadNext where feasible until a patch is available. 5) Educate developers and users about the risks of processing untrusted Lua code and enforce strict code review policies. 6) Use endpoint detection and response (EDR) tools to identify unusual memory access patterns or crashes related to NotepadNext. 7) Maintain up-to-date backups and incident response plans to quickly recover from potential exploitation consequences. These targeted measures go beyond generic advice by focusing on controlling Lua script execution and isolating the vulnerable application component.

Description

Out-of-bounds Read vulnerability in dail8859 NotepadNext (src/lua/src modules). This vulnerability is associated with program files lparser.C. This issue affects NotepadNext: through v0.11. The singlevar() in lparser.c lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.

References

Community reviews

Loading reviews…