CVE-2025-52939: dail8859 NotepadNext · Out-of-bounds Write
Affects dail8859 NotepadNextSource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical : upgrade to 0.11 as a priority.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.11
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/S:N/AU:Y/R:U/V:C/RE:M/U:RedExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade dail8859/NotepadNext to 0.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubdail8859/NotepadNextpkg:github/dail8859/NotepadNextOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediate mitigation should include disabling or restricting the use of Lua scripting within NotepadNext until patches are available, especially in environments where untrusted input is processed. 2. Employ application whitelisting and strict execution policies to prevent unauthorized or malicious scripts from running. 3. Monitor and audit usage of NotepadNext and related Lua modules for unusual behavior or crashes that could indicate exploitation attempts. 4. Implement network segmentation and least privilege principles to limit the impact of a potential compromise. 5. Engage with the vendor (dail8859) to obtain timely patches or updates addressing this vulnerability. 6. Where possible, replace NotepadNext with alternative text editors that do not have this vulnerability or that have been verified as patched. 7. Use runtime application self-protection (RASP) or endpoint detection and response (EDR) tools capable of detecting memory corruption or exploitation attempts related to out-of-bounds writes. 8. Educate developers and users about the risks of executing untrusted scripts and enforce strict code review policies for Lua scripts used within the organization.
Description
Out-of-bounds Write vulnerability in dail8859 NotepadNext (src/lua/src modules). This vulnerability is associated with program files ldebug.C, lvm.C. This issue affects NotepadNext: through v0.11.