CVE-2025-53003: JanssenProject jans · Information Exposure
Affects JanssenProject jansSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 1.8.0 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade janssenproject/jans to 1.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubjanssenproject/janspkg:github/janssenproject/jansOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediate upgrade to Janssen Project version 1.8.0 or later, where the vulnerability is patched. 2. If immediate upgrade is not feasible, apply the workaround by forking and patching the Config API following the guidance in commit 92eea4d to enforce proper scope verification. 3. Conduct a thorough audit of IAM logs and configurations to detect any unauthorized access attempts or anomalies prior to patching. 4. Implement network-level access controls to restrict access to the Config API endpoints to trusted internal networks or VPNs, minimizing exposure to external attackers. 5. Employ strict monitoring and alerting on IAM API usage to detect unusual patterns indicative of exploitation attempts. 6. Review and tighten IAM roles and permissions to limit the impact of any potential data exposure. 7. Educate development and security teams about the importance of scope verification and secure API design to prevent similar issues in the future.
Description
The Janssen Project is an open-source identity and access management (IAM) platform. Prior to version 1.8.0, the Config API returns results without scope verification. This has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This issue has been patched in version 1.8.0. A workaround for this vulnerability involves users forking and building the config api, patching it in their system following commit 92eea4d.
References
- github.com/JanssenProject/jans/security/advisories/GHSA-373j-mhpf-84wg (opens in a new tab)
- github.com/JanssenProject/jans/issues/11575 (opens in a new tab)
- github.com/JanssenProject/jans/commit/92eea4d4637f1cae16ad2f07b2c16378ff3fc5f1 (opens in a new tab)
- github.com/JanssenProject/jans/releases/tag/v1.8.0 (opens in a new tab)