Skip to main content
VulnerabilityPublished

CVE-2025-53478: Wikimedia Foundation Mediawiki – CheckUser extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – CheckUser extensionSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 1.44.0 : update Wikimedia Foundation Mediawiki – CheckUser extension when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.2, 1.43.0 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - CheckUser extensionAffected
  • >=1.39.0 <1.40.0
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
  • <1.39.13
  • <1.42.7
  • <1.43.2
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0
  • 1.39.13
  • 1.42.7
  • 1.43.2

AI-suggested

  1. Immediate upgrade of the CheckUser extension to the fixed versions: 1.39.13 or later for the 1.39.x branch, 1.42.7 or later for the 1.42.x branch, and 1.43.2 or later for the 1.43.x branch.
  2. Implement strict Content Security Policy (CSP) headers to restrict the execution of inline scripts and reduce the impact of XSS attacks.
  3. Limit access to the Special:Investigate interface to only highly trusted administrators and enforce multi-factor authentication (MFA) to reduce the risk of compromised credentials.
  4. Conduct regular security training for administrators to recognize and avoid phishing attempts that could deliver malicious URLs exploiting this vulnerability.
  5. Monitor web server logs and Mediawiki audit logs for unusual access patterns or suspicious query parameters targeting the Special:Investigate interface.
  6. If immediate patching is not possible, consider disabling the CheckUser extension temporarily or restricting its access via network-level controls (e.g., IP whitelisting).
  7. Review and sanitize all internationalized system messages and user-generated content rendered in administrative interfaces to ensure proper escaping and encoding.

Description

The CheckUser extension’s Special:Investigate interface is vulnerable to reflected XSS due to improper escaping of certain internationalized system messages rendered on the “IPs and User agents” tab. This issue affects Mediawiki - CheckUser extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…