Skip to main content
VulnerabilityPublished

CVE-2025-53480: Wikimedia Foundation Mediawiki – CheckUser extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – CheckUser extensionSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 1.44.0 : update Wikimedia Foundation Mediawiki – CheckUser extension when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.0, 1.40.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Wikimedia Foundation Mediawiki – CheckUser extension to 1.44.0, 1.43.0 or 1.40.0.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - CheckUser extensionAffected
  • >=1.39.0 <1.40.0
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0

AI-suggested

  1. Immediate patching: Upgrade the CheckUser extension to the fixed versions 1.39.13, 1.42.7, or 1.43.2 or later as applicable. This is the most effective mitigation.
  2. Input validation and output encoding: Review and enhance the handling of internationalized messages and user-supplied parameters to ensure proper escaping and sanitization before rendering in the UI.
  3. Restrict access: Limit access to the Special:Investigate page and the CheckUser extension features to trusted administrators only, reducing the attack surface.
  4. User awareness: Educate users with privileges about the risks of clicking suspicious links, especially those containing unusual query parameters like ?uselang=x-xss.
  5. Web Application Firewall (WAF): Deploy or update WAF rules to detect and block requests containing suspicious parameters or payloads targeting this vulnerability.
  6. Monitoring and logging: Enable detailed logging of access to the CheckUser extension pages and monitor for unusual or suspicious URL parameters or access patterns.
  7. Content Security Policy (CSP): Implement strict CSP headers to limit the execution of inline scripts and reduce the impact of XSS attacks.
  8. Incident response readiness: Prepare to respond to potential exploitation attempts by having procedures to revoke compromised sessions and credentials promptly.

Description

The CheckUser extension’s Special:Investigate page has a vulnerability in the Account information tab, where specific internationalized messages are rendered without proper escaping. Attackers can exploit this by appending ?uselang=x-xss to the URL, causing reflected XSS when the UI renders affected message keys. This issue affects Mediawiki - CheckUser extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…