Skip to main content
CVE-2025-53487VulnerabilityPublished

CVE-2025-53487: Wikimedia Foundation Mediawiki – ApprovedRevs extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – ApprovedRevs extensionSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 1.44.0 : update Wikimedia Foundation Mediawiki – ApprovedRevs extension when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.2, 1.43.0 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - ApprovedRevs extensionAffected
  • >=1.39.0 <1.40.0
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
  • <1.39.13
  • <1.42.7
  • <1.43.2
  • =1.39.0
  • =1.42.0
  • =1.43.0
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0
  • 1.39.13
  • 1.42.7
  • 1.43.2

AI-suggested

To mitigate this vulnerability, organizations should immediately upgrade the ApprovedRevs extension to the fixed versions: 1.39.13 or later for the 1.39.x branch, 1.42.7 or later for the 1.42.x branch, and 1.43.2 or later for the 1.43.x branch. If upgrading is not immediately feasible, administrators should disable the 'uselang' parameter override or implement strict input validation and output encoding to prevent unescaped HTML rendering of system messages. Employing Content Security Policy (CSP) headers can help mitigate the impact of injected scripts by restricting script execution sources. Regularly auditing MediaWiki extensions for security updates and monitoring logs for suspicious URL parameters or message keys is recommended. Additionally, user education on phishing and suspicious links can reduce the risk of exploitation via crafted URLs. Finally, restricting access to the wiki to trusted users and networks can limit exposure.

Description

The ApprovedRevs extension for MediaWiki is vulnerable to stored XSS in multiple locations where system messages are inserted into raw HTML without proper escaping. Attackers can exploit this by injecting JavaScript payloads via the uselang=x-xss language override, which causes crafted message keys to be rendered unescaped. This issue affects Mediawiki - ApprovedRevs extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…