CVE-2025-53489: Wikimedia Foundation Mediawiki – GoogleDocs4MW Extension · XSS or 'Cross-site Scripting'
Affects Wikimedia Foundation Mediawiki – GoogleDocs4MW ExtensionSource CVE Database V5
Not known to be exploited · CVSS 5.6 Medium : upgrade to 1.44.0 or 1.43.0 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.44.0, 1.43.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 3 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade wikimedia/mediawiki/extensions/GoogleDocs4MW to 1.44.0 or 1.43.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubwikimedia/mediawiki/extensions/GoogleDocs4MWpkg:github/wikimedia/mediawiki/extensions/GoogleDocs4MWOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately audit their Mediawiki installations to identify the presence of the GoogleDocs4MW extension and verify the version in use. If you cannot patch yet, organizations should consider disabling or removing the GoogleDocs4MW extension to eliminate the attack surface. Implementing strict Content Security Policies (CSP) can help mitigate the impact of XSS by restricting script execution sources. Additionally, input validation and output encoding should be reviewed and enhanced within custom extensions or templates interacting with GoogleDocs4MW. Monitoring web server logs and user activity for unusual patterns indicative of XSS attempts is recommended. Organizations should also educate users about the risks of clicking suspicious links or interacting with untrusted wiki content. Finally, maintain close communication with Wikimedia Foundation security advisories to apply patches promptly once released.
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - GoogleDocs4MW Extension allows Cross-Site Scripting (XSS).This issue affects Mediawiki - GoogleDocs4MW Extension: from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.