Skip to main content
CVE-2025-5352VulnerabilityPublished Updated

CVE-2025-5352: lunary-ai/lunary · Cross-site Scripting

Affects lunary-ai/lunarySource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 1.9.25 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.25
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade lunary-ai/lunary to 1.9.25.

Affected software

ProductAffectedFixed in
lunary-ai lunary-ai/lunaryAffected
  • <1.9.25
Fixed in
  • 1.9.25

AI-suggested

To mitigate this vulnerability, European organizations should immediately upgrade lunary-ai/lunary to version 1.9.25 or later, where the issue is fixed. Until the upgrade is possible, organizations should audit and sanitize the NEXT_PUBLIC_CUSTOM_SCRIPT environment variable to ensure it contains no malicious code. Implement strict validation and sanitization routines for any environment variables or user-controllable inputs that are injected into the DOM. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers. Conduct thorough security reviews of deployment pipelines to prevent unauthorized modification of environment variables. Additionally, monitor application logs and user activity for signs of exploitation or anomalous behavior. Educate development and operations teams about the risks of using dangerouslySetInnerHTML without proper sanitization. Finally, consider implementing runtime application self-protection (RASP) solutions to detect and block XSS attacks in real time.

Description

A critical stored Cross-Site Scripting (XSS) vulnerability exists in the Analytics component of lunary-ai/lunary versions up to 1.9.23, where the NEXT_PUBLIC_CUSTOM_SCRIPT environment variable is directly injected into the DOM using dangerouslySetInnerHTML without any sanitization or validation. This allows arbitrary JavaScript execution in all users' browsers if an attacker can control the environment variable during deployment or through server compromise. The vulnerability can lead to complete account takeover, data exfiltration, malware distribution, and persistent attacks affecting all users until the environment variable is cleaned. The issue is fixed in version 1.9.25.

References

Community reviews

Loading reviews…