Skip to main content
CVE-2025-54424VulnerabilityPublished Updated

CVE-2025-54424: 1Panel · Command Injection

Affects 1PanelSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 2.0.6 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.6
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade 1Panel to 2.0.6.

Affected software

ProductAffectedFixed in
1Panel-dev 1PanelAffected
  • <2.0.6
Fixed in
  • 2.0.6

AI-suggested

European organizations should immediately upgrade all affected 1Panel instances to version 2.0.6 or later, where the certificate validation flaw is fixed. Until patching is possible, organizations should restrict network access to the Core and Agent endpoints using firewall rules or network segmentation to limit exposure to untrusted networks. Implement strict TLS certificate pinning and validation policies where feasible to detect and prevent man-in-the-middle attacks. Conduct thorough audits of 1Panel configurations and logs to detect any unauthorized access attempts. Employ intrusion detection systems (IDS) and endpoint detection and response (EDR) solutions to monitor for suspicious command execution activities on servers running 1Panel. Additionally, enforce the principle of least privilege on accounts and services interacting with 1Panel to minimize potential damage from exploitation. Regularly review and update incident response plans to include scenarios involving RCE vulnerabilities in management interfaces. Finally, maintain awareness of any emerging exploit reports or threat intelligence related to this CVE to adapt defenses accordingly.

Description

1Panel is a web interface and MCP Server that manages websites, files, containers, databases, and LLMs on a Linux server. In versions 2.0.5 and below, the HTTPS protocol used for communication between the Core and Agent endpoints has incomplete certificate verification during certificate validation, leading to unauthorized interface access. Due to the presence of numerous command execution or high-privilege interfaces in 1Panel, this results in Remote Code Execution (RCE). This is fixed in version 2.0.6. The CVE has been translated from Simplified Chinese using GitHub Copilot.

References

Community reviews

Loading reviews…