Skip to main content
CVE-2025-54804VulnerabilityPublished

CVE-2025-54804: Eugeny russh · Integer Overflow or Wraparound

Affects Eugeny russhSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.54.1 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.54.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Eugeny russh to 0.54.1.

Affected software

ProductAffectedFixed in
Eugeny russhAffected
  • <0.54.1
Fixed in
  • 0.54.1

AI-suggested

European organizations should immediately audit their software inventories to identify any use of the russh library, particularly versions below 0.54.1. Systems using vulnerable versions must be upgraded to russh 0.54.1 or later to apply the fix for the integer overflow. Where upgrading is not immediately feasible, organizations should implement network-level controls to restrict SSH access to trusted clients and monitor SSH session behavior for anomalous channel window adjust messages. Enforcing strict authentication and access controls reduces the risk of exploitation since the vulnerability requires at least some level of authenticated access. Additionally, enabling Rust overflow checks during development and testing phases can help detect similar issues early. Logging and alerting on SSH server crashes or panics can provide early warning of attempted exploitation. Finally, organizations should incorporate this vulnerability into their incident response plans to quickly remediate any DoS events caused by this flaw.

Description

Russh is a Rust SSH client & server library. In versions 0.54.0 and below, the channel window adjust message of the SSH protocol is used to track the free space in the receive buffer of the other side of a channel. The current implementation takes the value from the message and adds it to an internal state value. This can result in a integer overflow. If the Rust code is compiled with overflow checks, it will panic. A malicious client can crash a server. This is fixed in version 0.54.1.

References

Community reviews

Loading reviews…