Skip to main content
VulnerabilityPublished

CVE-2025-54883: DavidOsipov Vision-ui · PRNG

Affects DavidOsipov Vision-uiSource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.5.0 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade DavidOsipov Vision-ui to 1.5.0.

Affected software

ProductAffectedFixed in
DavidOsipov Vision-uiAffected
  • <1.5.0
Fixed in
  • 1.5.0

AI-suggested

European organizations should immediately audit their software inventories to identify any use of Vision-ui versions 1.4.0 or below, especially those incorporating the security-kit module prior to version 3.5.0. The primary mitigation is to upgrade Vision-ui to version 1.5.0 or later, where the vulnerability is fixed. If immediate upgrade is not feasible, organizations should consider implementing compensating controls such as restricting network exposure of affected applications, applying strict access controls, and monitoring for anomalous activities related to token generation or authentication processes. Developers should review any custom cryptographic or random number generation code to ensure it does not rely on the vulnerable function. Additionally, penetration testing and code audits focusing on cryptographic implementations can help identify exploitation attempts or residual weaknesses. Organizations should also maintain up-to-date threat intelligence feeds to detect emerging exploits targeting this vulnerability.

Description

Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the getSecureRandomInt function in security-kit versions prior to 3.5.0 (packaged in Vision-ui <= 1.4.0) contains a critical cryptographic weakness. Due to a silent 32-bit integer overflow in its internal masking logic, the function fails to produce a uniform distribution of random numbers when the requested range between min and max is larger than 2³². The root cause is the use of a 32-bit bitwise left-shift operation (<<) to generate a bitmask for the rejection sampling algorithm. This causes the mask to be incorrect for any range requiring 32 or more bits of entropy. This issue is fixed in version 1.5.0.

References

Community reviews

Loading reviews…